Feedburner Feedsmith Plugin Security Issue

Burning Questions • The FeedSmith Plugin: newly fortified as part of this delicious breakfast

And you should probably get it pretty soon, since it's a security release.

Some WordPress plugins that permit the entry of user-entered values, such as older versions of FeedSmith, can be vulnerable to what is called a "cross-site request forgery." Without getting overly technical, this permits someone to change WordPress plugin settings on your system without you noticing during the time you are signed into your WordPress control panel. And no one wants that.